Wednesday , July 18 2018
Home / Information Security / Kali Linux Error: following packages have unmet dependencies
kali

Kali Linux Error: following packages have unmet dependencies

Print Friendly

While installing DHCP Server on Kali Linux, I faced following error:

The following information may help to resolve the situation:

The following packages have unmet dependencies:
dhcp3-server : Depends: isc-dhcp-server but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Shown Below:

error

After doing some Google search, I came across that I’ve made some changes previously in “/etc/apt/sources.list” file. I set the sources list to the defaults as described on Kali Linux support forum as:

# vim /etc/apt/sources.list

– Comment-out all previous lines by HASH mark # before every command and add following lines:

 

## Regular repositories
deb http://http.kali.org/kali kali main non-free contrib
deb http://security.kali.org/kali-security kali/updates main contrib non-free
## Source repositories
deb-src http://http.kali.org/kali kali main non-free contrib
deb-src http://security.kali.org/kali-security kali/updates main contrib non-free

 

As shown in below Screen capture:

source_list edit

Then Save & Exit clean previous Apt-Get downloaded data and updated Kali linux by:

# apt-get autoclean && apt-get clean all && apt-get update -y

updated

Then I executed DHCP Server Installation by APT Get again and:

# apt-get install dhcp3-server -y

re-installed dhcp

 

SuCCeSS  !!

About Muhammad Attique

Related Posts

my file

Installing & Configuring OpenVPN Client on Kali Linux

In this blog post, I am going to install and configure OpenVPN client on Kali …