Saturday , March 17 2018
Home / Information Security / Installing & Configuring WingIDE on Kali Linux (64-bit)
kali with wingide

Installing & Configuring WingIDE on Kali Linux (64-bit)

Print Friendly

Wingware Python IDE a.k.a. Wing IDE is a full-featured Python IDE designed for professional programmers. It includes powerful editor, code intelligence, refactoring, debugging, search, unit testing, project management, and revision control features.

Let us Install and Configure WingIDE on Kali Linux. Let us begin.

Softwares Versions I used to Install are:

Kali Linux:        Ver:    2.0   64-Bit

WingIDE:          Ver:    5.1.7-1 (rev 33992)   64-Bit

WingIDE I’m going to install is Professional, as I have license of this awesome product. You may download its free version a.k.a. Personal Edition or WingIDE 101 edition if don’t have its license.

Installing Dependencies:

  • Main required dependency for WingIDE is “libqt4-webkit”. To Install it, we first need to install Synaptic Package Manager. Install SPM by following command:
# sudo apt-get install synaptic -y
  • When installation is completed, open Synaptic Package Manager by searching for “synaptic” in Launchpad as shown below:



  • Now click on “Search” and search for “libqt4-webkit




  • Select the box before its name and select “Mark for installation”. Click Apply to install this.




  • Now, it’s time to Restart Kali Linux.


# sudo init 6

Installing WingIDE:

  • Download latest available stable version of WingIDE from following link.

Current latest version available is: 5.1.7-1 (rev 33992), so I’ll download file: wingide5_5.1.7-1_amd64.deb.

  • Open the Terminal window and follow the below given steps.
# cd /root/Downloads
# dpkg -i wingide5_5.1.7-1_amd64.deb
  • It should be successfully installed now and display following screen (some comments may be changed, but there must be no error.)




  • Now open newly installed WingIDE by searching for “wing” in Launchpad as shown below.




  • Done

About Muhammad Attique

Related Posts


Kali Linux Error: following packages have unmet dependencies

While installing DHCP Server on Kali Linux, I faced following error: Shown Below: After doing …